'CylonMinimal' Window Decoration for KDE

KDE 3.x Window Decorations

Source (required if based on other people's work): Add the source-code for this project on git.opendesktop.org

1
Score 73%
Description:

‘CylonMinimal’ for KDE 3.2+ is a windeco inspired by the Cylons of the new “Battlestar Galactica” - Series, created by Ron Moore.

-----------------------------------------


Installation:
Unpack and cd to the directory
./configure
make
sudo make install

In case it doesn’t work, please try to “prefix” your KDE directory, e.g. for Kubuntu ./configure –-prefix=/usr


-----------------------------------------

made with DecGen 0.5 http://kde-look.org/content/show.php?content=28848
Last changelog:

11 years ago

* (hopefully) fixed the bug with the white gap between the minimize and maximize button
* smaller radiuses at the buttons edges
* slicker titlebar reflections
* thinner borders (only 1 px)

wburnner

10 years ago

Hi, I use Kubuntu 8.04

I use terminal:

./configure -prefix=/usr

and later sample this message:

configure:3305: error: C compiler cannot create executables
See `config.log' for more details.

My log file:

http://pastebin.com/f161f6a1e

Please, can help me?

Report

artb1sh

10 years ago

You don't have a C++ compiler on there. You need to install the gcc-c++ package (while you're at it, install gcc as well if you haven't already). This can probably be done with apt-get, but I'm not sure how you use it.

Report

artb1sh

10 years ago

You don't have a C compiler

Report

pauelmaco

10 years ago

Good loock and good work

Report

SSteel

10 years ago

please make a left buttons theme
thanks
sorry for my bad english

Report

5tef

10 years ago

pls someone explane step by step how to install

Report

5tef

10 years ago

PLEASE

Report

5tef

10 years ago

configure: error: C++ preprocessor "/lib/cpp" fails sanity check

Report

5tef

10 years ago

Thanks to Exeon at:
http://www.linuxquestions.org/questions/showthread.php?t=124961

He said:
>I know this shouldn't be right.
>gcc was already installed on my machine but I still got:
>C++ preprocessor "/lib/cpp" fails sanity check
>I looked at config.log and it said something like:
>cc1plus command not found

>i found cc1
>/usr/lib/gcc/i586-mandrake-linux-gnu/3.4.1/cc1
>so I linked it in /usr/bin
>ln -s /usr/lib/gcc/i586-mandrake-linux-gnu/3.4.1/cc1 cc1plus

>voila: all working

Report

Xhan

11 years ago

Very cool. I'd really like to see this with a darker border though (blue or black).

Report

premierSullivan

11 years ago

Just an annoyance... for me, there is a little white gap between the minimize and maximize buttons. Doesn't seem to matter how i configure it. This is different from your screen shot. I'm using all three buttons... i tried with and without spacers, same story.

Report

Elessar911

11 years ago

Very clean and nice. Using it with shadows too. But I have two annotations:

1) When showing the application icon in the title bar there's too little space between it and the window title.

2) I would LOVE fading buttons as seen in the "Glow" theme. =)

Report

eldrich

11 years ago

This decoration is showing some drawing errors on the title bars. It seems to happen when choosing not to draw the application icon and having the titlebar text alligned to the left.

Report

ashenphoenix

11 years ago

The following worked on an Ubuntu 7.04 system:

./configure --prefix=$(kde-config --prefix)
make
sudo checkinstall

Report

chaotic

11 years ago

well I´ve complied it as u say but in the control-center it doesn´t appear :(


sry, my english sucks :D

Report

chaotic

11 years ago

ok, I got it: I have to use /usr as prefix

Report

PARENA

11 years ago

Even when using "make -f admin/Makefile.common && make clean" like suggested, no dice. That command gives:

*** YOU'RE USING autoconf (GNU Autoconf) 2.61.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Error 1

Makes no sense at all. :/

Report

enby

11 years ago

do u happen to use gentoo? if so, then syncronize ur portage and then emerge the newer gcc... worked for me

Report

PARENA

11 years ago

My system is up to date (AMD64). But like the error says: I need 2.53 or newer, but I HAVE newer: 2.61... weird...

Report

petersi

11 years ago

As on many different places, the make -f thingy-command is no good for there is some nutty version-checking in the admin/cvs.sh. This check is way too picky about version-numbers returned from automake.(I'd simply comment this part of the code out)

Furthermore, a lot of developers simply do not use a standard KDE-installation for testing (if they did, these kind of errors wouldn't show up so commonly!)
DEVELOPERS: Get it right, please!

Then: ./configure produces an error: expected an absolute directory-name for <...>
You have to go: make -f Makefile.cvs
Then ./configure (the plain command!), make and make install (as usual)

I'll now have a look if installation went into the proper subdirs...

Report

petersi

11 years ago

Nah, didn't think so. This package won't do on a plain Mandriva-install, nor a PCLinuxOS-install. Directories are not default, references to libraries are not standard.
Sorry, need some work.
I'd say: please do so, for the screen-shots are very nice and very original!

Report

petersi

11 years ago

Might work if you'd copy the material from /usr/local/<whatever> to /usr<whatever> or you MUST have the path to /usr/local/lib active (which is not standard under Mandriva).
Got it working and i'm happy...

Report

Brandybuck

11 years ago

Doesn't build for me either. Same errors as everyone else. Something in your build system is screwed up.

Report

Tryke

11 years ago

I'm impressed by your screenshots, but I can't get this to install. First off, some files weren't set to be executable, so I just did a "chmod 777 * -R" in the cylonminimal directory. After configure, I try to run "make" and get the following output:

ryan@KOMGZ:~/Downloads/cylonminimal-0.1$ make
make all-recursive
make[1]: Entering directory `/home/ryan/Downloads/cylonminimal-0.1'
Making all in kwin
make[2]: Entering directory `/home/ryan/Downloads/cylonminimal-0.1/kwin'
Making all in .
make[3]: Entering directory `/home/ryan/Downloads/cylonminimal-0.1/kwin'
/bin/bash ../libtool --silent --mode=link g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -O2 -fno-exceptions -fno-check-new -fno-common -o kwin3_cylonminimal.la -rpath /usr/lib/kde3 -L/usr/lib -L/usr/share/qt3/lib -avoid-version -module -no-undefined -R /usr/lib -R /usr/share/qt3/lib -R /usr/lib -module cylonminimal.lo -lkdeui /usr/lib/libkdecorations.la
g++: .libs/cylonminimal.o: No such file or directory
make[3]: *** [kwin3_cylonminimal.la] Error 1
make[3]: Leaving directory `/home/ryan/Downloads/cylonminimal-0.1/kwin'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/ryan/Downloads/cylonminimal-0.1/kwin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ryan/Downloads/cylonminimal-0.1'
make: *** [all] Error 2

any ideas?

Report

D3f0

11 years ago

The same here :'(

Report

11 years ago

* (hopefully) fixed the bug with the white gap between the minimize and maximize button
* smaller radiuses at the buttons edges
* slicker titlebar reflections
* thinner borders (only 1 px)

product-maker 42 122

File (click to download) Version Description Packagetype Architecture Downloads Date Filesize DL OCS-Install
Pling
Details
license
version
updated Oct 02 2007
added Jan 21 2007
downloads today
0
page views today 1
System Tags linux unix