QtCurve (KDE3) Kubuntu package

KDE 3.5 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5 .0
Description:

*** Some bad news and a good one. Lets start from the former, version 0.59.2 is the last one that will be packaged and posted here. I've passed to KDE 4 and I no longer use qtcurve. I'm sorry for everyone waiting for the new version to be packaged, but here goes the good news... compiling and packaging is really easy, you can try it yourself ;-) Good luck! ***

This is just the deb package for Kubuntu Linux of the QtCurve style (http://www.kde-look.org/content/show.php?content=40492&PHPSESSID=9668da50511cbf9f3027e247fa7a0f66)

How to install: 1) From a console go to the directory where you downloaded the package and type "sudo dpkg -i package_name.deb" replacing package_name with the one you downloaded.
2) From within KDE right click on the package then follow Kubuntu Package Menu-> Install Package.

To uninstall type in a console "sudo dpkg -r package_name"

*IMPORTANT*: Please remove previous versions BEFORE INSTALLING version 0.59.2 or later because of packaging system changes, thank you.

For other packages and GTK version go here: http://download.tuxfamily.org/lnxteam/packages/QtCurve/. Thanks to GuSArg for extra packaging and maintaining that web location.
Last changelog:

12 years ago

0.59.2
------
1. Also check in share/kde4/apps/kstyle/themes for qtc_*.themerc files.

notz

12 years ago

here you will also find up2date kde3,kde4 & gtk2 packages (i386, amd64)

deb http://ppa.launchpad.net/notz/ubuntu gutsy main

Report

Pensacola

13 years ago

Is there a package available who's name is qtcurve in stead of qtcurve-kde3?

Report

C

dresnu

13 years ago

Hmmm, what do you mean?
Are you talking about the repositories?

Report

aboe

13 years ago

could you please update the qtcurve gtk package also??

love the way qtcurve merges kde and gnome apps

Report

C

dresnu

13 years ago

I have compiled and packaged it for gtk, look at the last link. Hope it works as I can't test it right now. Also I can't promise I will update on a regular basis as I do for the KDE themes.

Report

MenaEng

13 years ago

Thanks anf if you need filehosting

www.filefront.com


Thanks,
Mena

Report

brazzmonkey

13 years ago

i suppose you should make previous version available as well, because latest qtcurve version has much less configuration possiblities than it used to...

Report

C

dresnu

13 years ago

There you go. I had in mind to upload when I upgraded to the new version because I knew someone might request it, I just didn't know where to host it.
If the rs link goes down I 'll re-up it.

Report

brazzmonkey

13 years ago

thanks for caring !

Report

Bram77

13 years ago

Thanks, I like it a lot. Escpecialy the inverted gradient.

Report

C

dresnu

13 years ago

Thanks, but send your positive feedback to CraigD on the original QtCurve post. He is the creator/maintainer of the theme, I just make these packages for kubuntu :-)

Report

Bram77

13 years ago

Done! Thank you for compiling for Kubuntu. I'm using Feisty, and it's perfect. :)

Report

GuSArg

13 years ago

Sorry, forgot, change the link in your description to that one :)

Report

C

dresnu

13 years ago

Done. Thank you.

Report

GuSArg

13 years ago

Hi again,

Add this link for K/Ubuntu Edgy AMD64 packages. There i will maintain those:

http://download.tuxfamily.org/lnxteam/packages/QtCurve/amd64/

Cheers.

Report

jeffbarish

14 years ago

I've never installed a theme before, so I'm missing something basic. I followed the installation directions under Description (both 1 and 2). The installation completed successfully. I can see that there is now a qtcurve directory in /usr/share/apps and there are files in /usr/lib/kde3, /usr/lib/kde3/plugins/styles, and /usr/share/apps/kstyle/themes. I go to Kcontrol | Appearance & Themes | Theme Manager. QtCurve is not listed there. I try Install New Theme, but there are no Theme Files in any of the places listed above.

Report

C

dresnu

14 years ago

Hmmm, that's strange... maybe there is some problem with the latest package I've uploaded, I can't think of anything else right now.
Try installing GuSArg's KDE version of the package from the link listed in the description. It's probably a slightly older version but nothing really dramatically different.
He creates packages in an other way so we 'll see if that works with you.

Report

anonymous-hive

14 years ago

Do you mean this link:

http://www.kde-look.org/content/show.php?content=40492&PHPSESSID=9668da50511cbf9f3027e247fa7a0f66

I downloaded the source labeled KDE 3 - 0.45.3. The ./configure fails with

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I haven't been able to figure out what package needs to be installed.

Report

anonymous-hive

14 years ago

Do you mean this link:

http://www.kde-look.org/content/show.php?content=40492&PHPSESSID=9668da50511cbf9f3027e247fa7a0f66

I downloaded the source labeled KDE 3 - 0.45.3. The ./configure fails with

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I haven't been able to figure out what package needs to be installed.

Report

anonymous-hive

14 years ago

Do you mean this link:

http://www.kde-look.org/content/show.php?content=40492&PHPSESSID=9668da50511cbf9f3027e247fa7a0f66

I downloaded the source labeled KDE 3 - 0.45.3. The ./configure fails with

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I haven't been able to figure out what package needs to be installed.

Report

C

dresnu

14 years ago

Actually I meant this link: http://www.lnxteam.org/downloads/pub/Kubuntu/qtcurve/.
You will find some debs there, download the KDE one.
Also if you want to compile a theme on your own you will need packages "build-essential" and "kdebase-dev".

Report

jeffbarish

14 years ago

That package won't install on my system:

sudo dpkg -i qtcurve-kde3_0.45.1-0ubuntu1_i386.deb
Selecting previously deselected package qtcurve-kde3.
(Reading database ... 88709 files and directories currently installed.)
Unpacking qtcurve-kde3 (from qtcurve-kde3_0.45.1-0ubuntu1_i386.deb) ...
dpkg: dependency problems prevent configuration of qtcurve-kde3:
qtcurve-kde3 depends on kdelibs4c2a (>= 4:3.5.3-1); however:
Version of kdelibs4c2a on system is 4:3.5.2-0ubuntu18.1.
qtcurve-kde3 depends on libc6 (>= 2.4-1); however:
Version of libc6 on system is 2.3.6-0ubuntu20.
qtcurve-kde3 depends on libfreetype6 (>= 2.2); however:
Version of libfreetype6 on system is 2.1.10-1ubuntu2.2.
qtcurve-kde3 depends on libgcc1 (>= 1:4.1.1-12); however:
Version of libgcc1 on system is 1:4.0.3-1ubuntu5.
qtcurve-kde3 depends on libstdc++6 (>= 4.1.1-12); however:
Version of libstdc++6 on system is 4.0.3-1ubuntu5.
dpkg: error processing qtcurve-kde3 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
qtcurve-kde3

The one from this page installs smoothly:

sudo dpkg -i 40920-qtcurve-kde3_0.45.3-1_i386.deb
(Reading database ... 88728 files and directories currently installed.)
Preparing to replace qtcurve-kde3 0.45.1-0ubuntu1 (using 40920-qtcurve-kde3_0.45.3-1_i386.deb) ...
Unpacking replacement qtcurve-kde3 ...
Setting up qtcurve-kde3 (0.45.3-1) ...

After installing it, am I supposed to see qtcurve on the list of themes in Theme Manager, or do I have to install it first (using Install New Theme)? If I am supposed to install it first, what is the theme file I am supposed to install? No files are getting through the Theme filter on the select theme file dialog in all the locations I thought to check, so I would like to try doing a find of the correct theme file.

Report

C

dresnu

14 years ago

After installing you should be able to see qtcurve in the selection list. You don't need to install the theme from theme manager, just install the package.
Are you running Edgy(6.10) or some older version of kubuntu?

Report

jeffbarish

14 years ago

I am running Edgy. Clean install.

Report

jeffbarish

14 years ago

Do you mean this link:

http://www.kde-look.org/content/show.php?content=40492&PHPSESSID=9668da50511cbf9f3027e247fa7a0f66

I downloaded the source labeled KDE 3 - 0.45.3. The ./configure fails with

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I haven't been able to figure out what package needs to be installed.

Report

12 years ago

0.59.2
------
1. Also check in share/kde4/apps/kstyle/themes for qtc_*.themerc files.

12345678910
Be the first to comment
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.59.2
updated May 14 2008
added Jun 15 2006
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0